answersLogoWhite
Ask
Auto Parts and Repairs
Ford Ranger
Ford Ranger XL
Ford Ranger XLT

How do you correct code P1443 on a 96 Ford Ranger?

464748
Answer

Top Answer
User Avatar
Wiki User
2014-06-04 16:52:39
2014-06-04 16:52:39

This is a code for the evaporative system which includes a black plastic container in the front of the engine comopartment that has hoses going to the tank and the throtle body. When it isn't running the fumes from the tank accumulate in this charcoal filled container and when the engine starts, they are burned. Something is wrong with the vacuum or electric solonoid on the top of this container. Or sometimes it can be set if the gas tank cap isn't on tight.

Personal Experiences:

I had the same code on my 96 Ranger (4.0). Investigating the evaporation system (vacuum hoses, solenoid, and canister) I found that the solenoid had extensive rust and corrosion. I replaced it with one from a junk 95 Taurus I had on hand. The code has not returned.

***Unfortunately, the P1443 code doesn't point to any one specific part of the evaporative emission system. I had my 96 Ranger to a local mechanic who ran a smoke test on the system. He said it had no leaks, and recommended changing the purge valve or solenoid (the valve located in the vacuum line closest to the charcoal canister). I replaced it (it looked very rusty on the bottom) and yet the code came back. I then replaced the purge flow sensor (located next to the purge solenoid, closer to the engine) and the code has not returned since. The purge flow sensor was bad.

There is supposedly another valve or sensor on top of the gas tank in this system, although I could not see it. So, the P1443 code can occur when any of the valves, flow sensor, or vacuum lines fail in the evaporative emission control system

0

Related Questions

User Avatar

Code P1443 is idle air Control (IAC) valve Speed fault

User Avatar

P1443 code evap emissions control malfuction no voltage at solenoid.

User Avatar

The p1443 code means a problem with the evaporative emissions system. There could be a problem with a broken or unhooked vacuum hose. Also could be a problem with the solenoid or sensor between throttle body and evaporative canister.

User Avatar

P1443 EVAP System - Tank Cap Missing Mostly it may be damaged. usually appears with code P0455

User Avatar

i have a 99 ford ranger xlt. my code scanner connector is not working,is there a fuse for it


Copyright © 2020 Multiply Media, LLC. All Rights Reserved. The material on this site can not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Multiply.