How do you make it so that a question you edit or answer never goes on your Watchlist?

Click the "My settings" in the left-blue pod and then uncheck the "Add pages you edit to your Watchlist by default." checkbox.