What are the system requirements for Windows Movie Maker?

System requirements for Windows Movie Maker v2.1 can be found at this URL:

http://www.microsoft.com/windowsxp/downloads/updates/moviemaker2.msp
___________________________________________

System requirements for Windows Movie Maker v2.6:

  • Supported Operating Systems: Windows Vista; Windows Vista Business; Windows Vista Enterprise; Windows Vista Home Basic; Windows Vista Home Premium; Windows Vista Starter; Windows Vista Ultimate
Movie Maker v2.6 requires a version of Microsoft Windows Vista that has the Vista version of Movie Maker already installed.