Dashboard Lights and Gauges
VW Jetta
Ford Windstar SE

Why would a 94 Jetta speedometer stop working when the tachometer still works?

596061

Top Answer
User Avatar
Wiki User
Answered
2005-11-14 19:19:06
2005-11-14 19:19:06

The wires on the back of the gauge pod could have possibly come loose. Two of the screws that hold the gauge assembly in are hidden behind the air vents, they just pull out at a slight downward angle.

012
๐Ÿ˜‚
0
๐ŸŽƒ
0
๐Ÿคจ
0
๐Ÿ˜ฎ
0
User Avatar

Related Questions


Replace the dash cluster that's what it sounds like to me since your tachometer and speedometer both don't work





There are a few reasons that could cause the speedometer to stop working on your Toyota Camry. If the mileage is still working then the speedometer cable end is damaged. If both the odometer and speedometer do not work then the cable is most likely broken.


Since you replaced the sensor, and the speedometer still isn't working it is possible that you will need to replace the speedometer cable. Check the cable first to be sure that it is still properly connected, and if so replace the cable to see if that solves the problem.



- I have a 2002 Caravan with the similar symptoms - speedometer stopped working but tripometer and odometer still work. The speedometer needle is wrapped all the way around past the top speed and resting on the bottom of the needle resting peg. I saw a posting about reseting the dashboard by removing the IOD fuse and replacing it but that did not help. I also tried pressing the trip button in and turning the ignition on as described in another post with no luck. Has anyone solved this or do I have a faulty speedometer requiring replacement? thanks Steve


SOUNDS LIKE A BLOWN FUSE DOES YOUR TAIL LIGHTS STILL WORK? 99.9 % THE TAIL LIGHTS ARE ON THE SAME CIRCUT AS THE matker LIGHTS -TAIL LIGHTS


Maybe a broken cable The needle on the speedometer of the 96 aspire is still moving, but it acts like it is out of control.



If the odometer has failed, does the speedometer still work? They are both driven by a cable which spins. If the speedometer is still working, than the odometer has jammed. Probably a dealer fix.


Stepper motor for speedometer has a broken gear in it, causing unpredictable operation. If the odometer is still working, then the speed sensor is OK. Instrument cluster needs repair.


If the odometer stopped working and the speedometer and cruise control still work, you have a bad odometer. It is part of the speedometer assembly so the whole thing will have to be replaced.


If the ABS light is flashing it means the system is malfunctioning but still working. The dash light behind the speedometer is burnt out.


There isn't a speedometer cable. There is a speedometer sensor,where it is located I am still trying to find out. On the tranny or in the speedometer or somewhere else?


Have speedometer head repaired professionally or replace speedometer head


I took my 02 liberty 6 cyl. to have it diagnosed. Stated that the speed output sensor was bad. I bought a new one and replaced it. (There are two sensors on this transmission - input and output) Speedometer still not working! I swapped sensors, since it is the same sensor for input or output, but still no speedometer working. There are two more sensors in the differential. Those did not appear on the diagnostic tool but i might consider replacing. If anyone has ran into this problem yet, please spread the wealth. Thanks.


We had the same problem, and our 1998 F150 needed a new instrument cluster.


Call the dealer, and ask for the different kinds of speedometer gears, you'll be lucky if you can still get one. They Usually go by color and teeth count. If I remember right, they are the typical cause.


Don't know, but I think this is a problem with this vehicle/year. Ours was fixed for free by the dealer.


if the cluster still lights up but the speedo still inop possible cause is the speed sensor in the transmition


you maybe needing to replace your speed sensor. mine is doing the same thing and that is what is wrong with it


remove cluster fuse to reset cluster....if still not working properly replace cluster


I'm not 100% certain, but I believe that model year still uses a mechanical speedometer, in which case, it's likely either your speedometer cable or faulty gears in the speedometer itself. If it is electronic - which is possible, as again I'm not 100% certain that the 95 uses a mechanical speedometer - and the rest of your gauges are working, there'll be a speed sensor on the transmission with an electrical pigtail running to it... faulty sensors or faulty wiring are the probable causes.



Copyright ยฉ 2020 Multiply Media, LLC. All Rights Reserved. The material on this site can not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Multiply.