Why would the sound be scratchy when watching a DVD movie on the computer?

here are some contributor opinions:

  • If you turn down the CD volume in the main sound board controls of the computer. that helped. the sound controls can be found in the control panel.
  • Also, try shutting down any unnecessary programs that are using processor time and memory. Displaying a DVD movie requires moving a large amount of data. Any bottlenecks can cause an interruption in the data stream. Even a brief interruption can be heard as a popping or skipping sound, and can cause jerkiness in the picture.
  • Try uninstalling and reinstalling your player program.
  • Try using a different DVD player program. The installation of the program that you are using may be corrupted, or just may not be compatible with your particular OS/hardware configuration.
  • It also might be your sound card that might be the problem. if you have a sound card that came with your computer installed already, you might want to think about buying a new one. i threw out my old one because my sound was bad overall. i thought it was my speakers but a best buy salesman said it wasnt. i recommend getting creative lab sound card.
  • Try troubleshooting: Unplug your speakers & plug in a pair of headphones instead. Did the crackle go away? then the problem is your speakers, if not then the problem is in your system.
  • Do other programs also crackle? If all programs crackle, then you might have a bad sound card or soundcard drivers, try reinstalling your soundcard drivers & see if that helps.
  • Other programs don't crackle, just the DVD player. Try a different player program, if youre using powerdvd or something, try VLC & vice versa. If other players are okay, dig around in the audio settings and turn down things like hardware acceleration, tinker with the settings, but be sure to note what the original settings are in case you make matters worse.
  • If some programs crackle but others don't & there doesnt seem to be any rhyme or reason to it, you may benefit by disabling audio hardware acceleration. To do this go into the control panel, open "sounds and audio devices" in the "audio" tab click the "advanced" button under sound playback/default device, and in that window in the peformance tab, drag the "hardware acceleration" slider all the way left. (These directions are for windows XP, these settings may be in other places in other versions of windows)
  • Like any computer hardware problem, narrow down your problem as much as possible. The process of eliminition is the most important tool in cases like this.
  • I updated the firmware on my DVD/CD drive and it solved the problem for my computer - Dell M6300.
  • Another problem may be that you are overdriving (causing clipping of the signal) the input to one of your devices. Are you using amplified speakers? Try lowering the volume control on the computer and increasing the volume control on the speakers. Open your computer's volume controls and try adjusting the sliders to see if a different combination of setting reduces/eliminates the problem.