Asked in
Java Programming
Windows 8

How do you stop the error 'java' is not recognized as an internal or external command operable program or batch file?

Answer

User Avatar
Wiki User
September 25, 2012 1:53PM

If you are getting that error, it means that either Java is not installed, or is not in your path.

If Java is not installed, go to http://www.java.com to install the most recent version of the JRE.

If you're sure you have already installed Java ensure the Java executable is in your system's path. You can do this by first finding the directory it is installed in. For example, mine is installed in C:\Program Files\Java\jre6. The executables are located in the bin directory.

In order to set your path (Assuming Windows Vista), go to Start -> Control Panel -> System, then click on the 'Advanced System Settings' link on the left, then the 'Environment Variables' button. In the lower section (Labeled 'System Variables'), scroll through and find the item labeled 'Path' and double click it. In the field labeled 'Variable value' go to the end and add a semicolon (;), and then the path your installation of Java is located. Using the example I gave above, I would have added ;C:\Program Files\Java\jre6\bin to the end of the line.

The procedure for 64-bit Windows Vista or Windows 7 is the same, except the text you will add to the Path variable is ";C:\Program Files (x86)\Java\jre6\bin". Notice there is still a semi-colon at the beginning of the line.

Once you have done this, you will need to close and reopen the command prompt if it is already open, and you should be able to run java without getting this error message.