I have Mount and Blade version 1.033 the latest but i want the mod 300 which plays only in the mod 0.808.What should i do?

For a start there is no such thing as a version 1.033 the latest one is 1.011, and if it is a 0.808 version (if you are desperate to play it) uninstall mount and blade, then google mount and blade .808 and download it, make sure to save your files. then when you are sick of it, just update it with a patch. I do this when i want to play the mod The Last Days. :)