Heating AC and Engine Cooling
Cadillac DeVille
Combustion Engines

What would cause the fans on an 85 Cadillac Sedan DeVille to not cool the radiator?

262728

Top Answer
User Avatar
Wiki User
2004-10-07 21:09:00
2004-10-07 21:09:00

Either the inside of the rad is plugged, so you need to flush it, or the vanes are plugged with dirt, bugs, leaves, etc. You will need to pressure wash it from the inside of the engine compartment. Your water pump could be shot.

1
๐Ÿ™
0
๐Ÿคจ
0
๐Ÿ˜ฎ
0
๐Ÿ˜‚
0

Related Questions

User Avatar

8 to 12 miles per gallon . cause i own one "D

User Avatar

when overheating occurs at highway speeds the cause is usually. a radiator or coolant circulation problem, Check for a restricted or clogged radiator.

User Avatar

The DeVille could have low transmission. Or the internal transmission bands or valves could have failed. The transmission will most likely need a rebuild.

User Avatar

There are several things that can cause your Cadillac Deville to have transmission problems. The most common transmission problems are worn transmission gears.

User Avatar

O2 sensor, and catalytic converter can be ruined. You can also cause internal damage to the engine, depending on what the problem is. Have it repaired.

User Avatar

check radiator for small leaks or cooling lines which would most definitely cause it 2 steam when running after awhile

User Avatar

dirt in the speed snsor bad speedo head in the dash

User Avatar

One reason a 1998 Cadillac Deville would cut off while driving could be the fuel pump or the car is out of fuel. Another reason could be the spark plugs.

User Avatar

If the pedal is stuck down, no vacuum to the release diaphragm on the pedal

User Avatar

Well... mines doing the same thing. 88 sedan deville, 4.5 ltr v8. It turns over but I watch and nothing is coming through the injectors... no fuel. It happens off and on, sometimes it works and sometimes it doesn't. I think it might be the fuel filter but i can't find that thing.

User Avatar

7.5 with filter! Previous answer is incorrect, if you put in 8 with filter change you will be half quart over and cause problems!

User Avatar

My first diagnosis would be a blown freeze plug, check that and you may find your problem.

User Avatar

Possibly a clogged fuel filter. or faulty fuel pump, amongst other things

User Avatar

put a new motor in. it'll cost about the same as fixing the rear main that is more than likely the cause of the problem.

User Avatar

short in dash light circuit, but also check tailights. Sometimes no dash lights, AND NO TAILGHTS.


Copyright ยฉ 2020 Multiply Media, LLC. All Rights Reserved. The material on this site can not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Multiply.