When the power door on a 99 Toyota Sienna XLE opens but doesn't close how to you remedy the problem?

I've had this problem several times, almost always when someone new attempts to "manually" open or close the door. The sensor is at the bottom at the back of the door LATCH area. When the front of the door goes all the way back, this latch at the bottom is supposed to engage the sensor. When both parts are linked up correctly, the door will close correctly. The "sensor" is the part that closes the door automatically. I have wrestled with this several times. If the door won't close automatically (using the buttons), yank it closed manually a few times, reopen the door using the buttons, and see if the latch and sensor will link back up. I've had it take as long as a week, trying daily, before everything seems to get back in sync and the door magically opens and closes correctly. Not a terribly technical answer, however it has worked repeatedly for me (four kids with lots of friends that open the door wrong). Also check and make sure the kids have not accidentally jambed the lock into the locked position (same problem, someone new was in the van and pressed the "door open" button on the handle instead of the power door button. The solution to fix this is to use your ignition key to gently pry the door button back out of the handle. Also make sure the lock itself was not engaged. Then start back and the top of this post, cycle the door several times, and it will eventually get back in sync and start working automatically.