Chevy Corvette
Chevy Silverado
Chevy S-10
Heater Cores and Blower Fans

How do you fix No low and medium blower speed when high speed blower works fine on a 1987 Corvette?

333435

Top Answer
User Avatar
Wiki User
2006-05-11 12:37:53
2006-05-11 12:37:53

More than likely the blower resistor is bad....I recently ran into this problem in my 91 Vette...Hope this helps!

1
๐Ÿ™
0
๐Ÿคจ
0
๐Ÿ˜ฎ
0
๐Ÿ˜‚
0

Related Questions

User Avatar

Probably your blower motor speed resister is burned out.

User Avatar

The blower motor works on only one speed. The blower motor resitor pack is defective and needs to be replaced. It is located on the blower housing in the engine compartment just below the blower motor.

User Avatar

If the one speed it works on is high speed, it is the blower motor speed resisitor that is bad.

User Avatar

Assuming that by "high," "low," and "medium" you are referring to HVAC blower fan speed and that this happens with heat as well as with AC: Replace the blower resistor. It's no good.

User Avatar

The blower motor speed resistor is burned out.

User Avatar

The blower resistor has failed.The blower resistor has failed.

User Avatar

More than likely the blower motor speed resistor is burned out.

User Avatar

If the blower works on slower speeds only I would suspect the high speed blower motor relay (under the hood in the power distribution box) or the switch itself. The blower speed resistor is working if all the slower speeds work.

User Avatar

It's the blower resistor, it's a common problem in Xterras and it's easy to replace....

User Avatar

There is a resistor near the blower that is bad, known cause is high speed only.

User Avatar

need a new blower motor control module. This is a common thing. They cost about $25 and just plug in. most often are located under the dash right by the blower. Need to have smaller sockets to remove trim panel and take cover off where the module plugs in.

User Avatar

Normally when a heater blower motor only works on the High setting, it is caused by a defective Blower Motor Resistor Pack. The fix is to, Replace it. In very rare instances it can also be a defective blower motor speed control switch, but rarely.

User Avatar

If you are saying that the blower motor only works on the high speed setting, then the Blower Motor Resistor is defective and needs replacing.

User Avatar

The blower motor speed resistor is burned out. You can replace only the resistor but the resistor probably burned out because the blower motor is going bad. If you want to fix it for good, replace both the blower motor and blower motor speed resistor.

User Avatar

That would be caused by the blower resistor.

User Avatar

If the blower works on the defrost mode only, you could have a disconnected vacuum supply line coming from the engine. If the blower motor doesn't work on any mode or speed you could have a blown fuse, burned out blower motor speed resistor, bad switch or a bad blower motor.

User Avatar

The most likely problem is the blower resistor located behind the glove box door.

User Avatar

99% of the time, the blower motor relay, or resistor block,will be bad if the fan motor only works on high speed.

User Avatar

the resistor for the blower motor is busted blower works on high with out it


Copyright ยฉ 2020 Multiply Media, LLC. All Rights Reserved. The material on this site can not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Multiply.