answersLogoWhite
Spark Plugs and Wires
Buick Riviera
Toyota Camry
Ford Ranger XL
How To

How to get a 1992 Buick Riviera to start again after unplugging BCM you have crank and gas but no spark?

474849

Top Answer
User Avatar
Wiki User
2006-02-08 18:16:28
2006-02-08 18:16:28

Disconnect the battery, wait 5 seconds, and reconnect it. It should start then. When you replace any electronic or electrical, the computer will not realize it until the car's computer is "reset". To do this, you must unhook, and the rehook the battery.

1

Related Questions

User Avatar

1972 Buick Riviera. Also known as a "Boat tail".

User Avatar

No spark? are you sure? then probably bad crank sensor, or ignition module.

User Avatar

what can cause a 2002 buick lesabre to not crank

User Avatar

behind the harmonic balancer (crank pulley). you need a special puller, and 1/2 drive impact wrench to change it.

User Avatar

You need an oscilloscope. I use a vantage, it costs like $3K. now the crank sensor only cost like $40, but have to remove the harmonic balancer to change it. Now their is the delimna mechanics always face.

User Avatar

behind the crank pulley

User Avatar

You put a new crank sensor in your 92 buick and now its like its out of time?

User Avatar

could be the crank sensor, the go out. the have a reputation for that.

User Avatar

How to take out crank shaft on century 2001 buick century

User Avatar

Bad ignition module, crank sensor, or coil pack. Especially if yours is equipped with the magnavox coil pack vs the delco coils which have 3-seperate coils.

User Avatar

Both the CAM and Crank sensor are on the front of engine. The cam semsor is to the right and held in with two smaller screws. It is actually a sealed Hall Sensor device but pretty easy to change.

User Avatar

1992 buick road master after you put a new battery it crank but wont start what is the problem

User Avatar

Just like all the other 100+ posts on this site. Need to know if loosing spark, or fuel. Common causes are bad ignition module, or coil pack-specially if you have the single "magnovox" unit, or crank sensor.

User Avatar

under the crank pulley, right side of car under front of engine

User Avatar

No. The engine won't run with a faulty crank sensor.

User Avatar

a '95 riviera does not have a distributor. If you mean the ignition coils, then you probably looking at bad ignition module-located under the coils. Or bad crank sensor.

User Avatar

Usually it is a crank/no start, with either no signal to the coils or injectors. Check your fuses/relays first. If you have access to a scan tool would speed things up. Then just do the normal fuel pump are you getting pressure, spark at the plugs, noid light to check injector driver signal. Could be a cam/crank sensor.

User Avatar

Possibly the crank case oil sensor. Had the same symptoms on a Buick LeSabre '91

User Avatar

Crank Pulley, crank sensor, ignition module, dirty maf sensors, clogged fuel filters.

User Avatar

1st thing to do is get a test light, and see if you are getting voltage to the starter. If you cant do this, then don't waste money buying parts-take it to a mechanic. You may have a security system problem. you may need a new crank sensor

User Avatar

"http://wiki.answers.com/Q/Where_is_the_crank_sensor_on_a_1990_2.5_buick_skylark"


Copyright © 2020 Multiply Media, LLC. All Rights Reserved. The material on this site can not be reproduced, distributed, transmitted, cached or otherwise used, except with prior written permission of Multiply.